aboutsummaryrefslogtreecommitdiffstats
path: root/src/pkg/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Brown <nickbroon@gmail.com>2021-08-10 09:20:32 +0100
committerAndrew Yourtchenko <ayourtch@gmail.com>2021-08-12 12:24:40 +0000
commitb8e7a45d56be9f3e11b07b82fd899160e2af1bf1 (patch)
treec984f33a04d7bcbf53c03edca5d5d4565129af4e /src/pkg/CMakeLists.txt
parentafbb33aaf254ebfe6ebf2477b1a4859cec40e34b (diff)
build: consistent debhelper 10 support
Type: fix debian/compat contents were set to 10, but debhelper build dependency, which is the same thing, was set to only 9. Both are not needed, debian/compat being deprecated, so use only the latter. At compat level 10, dh-systemd is integrated directly into debhelper, so build dependency not needed (And in Debian Bullseye dh-systemd transitional package is completely removed). See: https://manpages.debian.org/testing/debhelper/debhelper.7.en.html#COMPATIBILITY_LEVELS Signed-off-by: Nick Brown <nickbroon@gmail.com> Change-Id: I5809b739334076d7fa8389b076a97f1648726e6e
Diffstat (limited to 'src/pkg/CMakeLists.txt')
-rw-r--r--src/pkg/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/pkg/CMakeLists.txt b/src/pkg/CMakeLists.txt
index d447774a1fd..892ef71fb5e 100644
--- a/src/pkg/CMakeLists.txt
+++ b/src/pkg/CMakeLists.txt
@@ -53,8 +53,6 @@ foreach(f copyright vpp.preinst vpp.postrm vpp.postinst vpp.service)
)
endforeach()
-file(WRITE ${VPP_BINARY_DIR}/debian/compat "10\n")
-
add_custom_target(pkg-deb
COMMENT "Building .deb packages..."
WORKING_DIRECTORY ${VPP_BINARY_DIR}