aboutsummaryrefslogtreecommitdiffstats
path: root/src/pkg/debian
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2020-05-12 12:22:18 +0200
committerFlorin Coras <florin.coras@gmail.com>2020-05-15 23:42:40 +0000
commita416493d3b9017181054d5ff24d5efdcdb5bf39f (patch)
tree960b1d9cafdcbb91f218999c14b82d86a42af6c8 /src/pkg/debian
parentd466c0cafcbc3189b5982f3df8d4cd4d553704ce (diff)
misc: fix ubuntu 20.04 python deps
Type: fix Change-Id: I9cdfbffd6333d090f970422bf047aaa90c1e4c65 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/pkg/debian')
-rw-r--r--src/pkg/debian/control.in (renamed from src/pkg/debian/control)4
-rwxr-xr-xsrc/pkg/debian/rules.in13
2 files changed, 10 insertions, 7 deletions
diff --git a/src/pkg/debian/control b/src/pkg/debian/control.in
index 48de48ab115..0b0c621e50c 100644
--- a/src/pkg/debian/control
+++ b/src/pkg/debian/control.in
@@ -5,9 +5,7 @@ Maintainer: fd.io VPP Packaging Team <vpp-dev@fd.io>
Build-Depends: debhelper (>= 9),
dh-systemd,
dh-python,
- python-all,
- python3-all,
- python3-setuptools
+ @VPP_DEB_BUILD_DEPENDS@
Standards-Version: 3.9.4
Package: vpp
diff --git a/src/pkg/debian/rules.in b/src/pkg/debian/rules.in
index ceef46a297a..f09db38e2a1 100755
--- a/src/pkg/debian/rules.in
+++ b/src/pkg/debian/rules.in
@@ -9,18 +9,23 @@ include /usr/share/dpkg/default.mk
export PYBUILD_NAME = vpp-api
export PYBUILD_DIR = @CMAKE_SOURCE_DIR@/vpp-api/python
-export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
-export PYBUILD_DISABLE_python2=test
export PYBUILD_DESTDIR_python3=debian/python3-vpp-api/
export PYBUILD_DISABLE_python3=test
export PYBUILD_SYSTEM=distutils
-
+ifeq (@VPP_DEB_WITH_PYTHON2@,yes)
+export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
+export PYBUILD_DISABLE_python2=test
buildvers := $(shell pyversions -sv)
+DH_WITH = systemd,python2,python3
+else
+DH_WITH = systemd,python3
+endif
+
build3vers := $(shell py3versions -sv)
# main packaging script based on dh7 syntax
%:
- dh $@ --with systemd,python2,python3 --buildsystem=pybuild
+ dh $@ --with $(DH_WITH) --buildsystem=pybuild
override_dh_strip:
dh_strip --dbg-package=vpp-dbg