aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/acl/CMakeLists.txt
diff options
context:
space:
mode:
authorMohammed Hawari <mohammed@hawari.fr>2024-03-14 22:51:55 +0100
committerAndrew Yourtchenko <ayourtch@gmail.com>2024-03-28 16:56:32 +0000
commitdcb5eb5a18bf42cb4d39ae29822664f2cb57622c (patch)
tree22888d08d89d02c05ccf16f759a0c19dd511e196 /src/plugins/acl/CMakeLists.txt
parent7c2a3357f32ae02bcc20cdad6d87beda39f71d31 (diff)
acl: rework headers to enable out-of-tree usage
Change-Id: I1f8adf1f5650ab6c04e03c95d7a8d0bfa39b5f2d Type: improvement Signed-off-by: Mohammed Hawari <mohammed@hawari.fr>
Diffstat (limited to 'src/plugins/acl/CMakeLists.txt')
-rw-r--r--src/plugins/acl/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/plugins/acl/CMakeLists.txt b/src/plugins/acl/CMakeLists.txt
index c43dd23ea51..1bb60d94fbe 100644
--- a/src/plugins/acl/CMakeLists.txt
+++ b/src/plugins/acl/CMakeLists.txt
@@ -30,4 +30,15 @@ add_vpp_plugin(acl
API_TEST_SOURCES
acl_test.c
+
+ INSTALL_HEADERS
+ exports.h
+ exported_types.h
+ acl.h
+ fa_node.h
+ public_inlines.h
+ types.h
+ hash_lookup_types.h
+ lookup_context.h
+ hash_lookup_private.h
)