aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/arping/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Luong <sluong@cisco.com>2021-02-14 11:37:02 -0800
committerBeno�t Ganne <bganne@cisco.com>2021-04-02 08:44:52 +0000
commita77ae4708906b2a7894f7ac694bf55d5f0558d5f (patch)
treec62c174032c9605250ecfe44ce857cfae8943356 /src/plugins/arping/CMakeLists.txt
parent19be32876f0587067e72c92b4d1faf5d4c26b3cd (diff)
arping: add arping command
Add linux similar arping command to VPP. syntax: arping [gratuitous] <address> <interface> [repeat <count>] [interval <secs>] Type: feature Signed-off-by: Steven Luong <sluong@cisco.com> Change-Id: I9267c054235207b8fae8e3f159246777eb0340dd
Diffstat (limited to 'src/plugins/arping/CMakeLists.txt')
-rw-r--r--src/plugins/arping/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/plugins/arping/CMakeLists.txt b/src/plugins/arping/CMakeLists.txt
new file mode 100644
index 00000000000..afec21e7d8e
--- /dev/null
+++ b/src/plugins/arping/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright (c) 2021 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(arping
+ SOURCES
+ arping.c
+ arping_api.c
+
+ API_FILES
+ arping.api
+
+ API_TEST_SOURCES
+ arping_test.c
+)