aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/avf/CMakeLists.txt
diff options
context:
space:
mode:
authorChenmin Sun <chenmin.sun@intel.com>2020-11-19 23:13:30 +0800
committerDamjan Marion <dmarion@me.com>2021-03-26 08:30:54 +0000
commitffe9a5489499467dfb5a2ee0fed14e397f5f825c (patch)
tree317bc75b046ebe13f27a99b6929a706140a5183a /src/plugins/avf/CMakeLists.txt
parent89c98a4bff101ad4270724bde7ca6f21ba4c8482 (diff)
avf: add avf flow framework
This patch adds the flow support to VPP avf_plugin. Currently only IP4-N-TUPLE and GTPU flow are supported as a reference. More flows will be added later. Type: feature Signed-off-by: Chenmin Sun <chenmin.sun@intel.com> Change-Id: I563dbfacecd3eba31e8c3c7769142ea6adba54b6
Diffstat (limited to 'src/plugins/avf/CMakeLists.txt')
-rw-r--r--src/plugins/avf/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/plugins/avf/CMakeLists.txt b/src/plugins/avf/CMakeLists.txt
index 8547fb76c9c..95fde7ceff8 100644
--- a/src/plugins/avf/CMakeLists.txt
+++ b/src/plugins/avf/CMakeLists.txt
@@ -20,6 +20,8 @@ add_vpp_plugin(avf
output.c
plugin.c
avf_api.c
+ flow.c
+ avf_fdir_lib.c
MULTIARCH_SOURCES
input.c