aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cnat/CMakeLists.txt
diff options
context:
space:
mode:
authorNathan Skrzypczak <nathan.skrzypczak@gmail.com>2021-02-25 12:06:11 +0100
committerFlorin Coras <florin.coras@gmail.com>2021-02-26 01:55:07 +0000
commitcc9a1a0d39f22f653801f5d08bfe4892325254b5 (patch)
treec19e3ebea400c7cba3009d8e31097e2c40dfad88 /src/plugins/cnat/CMakeLists.txt
parent4d237874e5c9922330c62ac1b003a9a171c1bc3b (diff)
cnat: add input feature node
This allows to configure nat on a per-interface basis. Special care must be taken to ensure the configuration remains consistent. Type: feature Change-Id: I352b2dce182e09d30813ce958333bb1ff37d9b4e Signed-off-by: Aloys Augustin <aloaugus@cisco.com> Signed-off-by: Nathan Skrzypczak <nathan.skrzypczak@gmail.com>
Diffstat (limited to 'src/plugins/cnat/CMakeLists.txt')
-rw-r--r--src/plugins/cnat/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/cnat/CMakeLists.txt b/src/plugins/cnat/CMakeLists.txt
index 95b59e97d10..6eb5968e703 100644
--- a/src/plugins/cnat/CMakeLists.txt
+++ b/src/plugins/cnat/CMakeLists.txt
@@ -17,6 +17,7 @@ add_vpp_plugin(cnat
cnat_client.c
cnat_node_snat.c
cnat_node_vip.c
+ cnat_node_feature.c
cnat_scanner.c
cnat_session.c
cnat_translation.c