aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/crypto_ipsecmb/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-04-11 08:18:34 +0000
committerDamjan Marion <dmarion@me.com>2019-04-11 15:12:58 +0000
commit21ada3bd7e9bc5cca7c2c8399adcbaa044bf8103 (patch)
tree845b74dfee811bfe27f3feef6a608d349e99436d /src/plugins/crypto_ipsecmb/CMakeLists.txt
parent5e282e93ad9f961d332cac9a033be33542979848 (diff)
IPSEC-MB: Use random & non-repeating IV (VPP-1642)
hard code IV and key lengths based on cipher. Init IV from random data, use AES instruction to rotate. Change-Id: I13a6507d12267b823c528660a903787baeba47a0 Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/crypto_ipsecmb/CMakeLists.txt')
-rw-r--r--src/plugins/crypto_ipsecmb/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/plugins/crypto_ipsecmb/CMakeLists.txt b/src/plugins/crypto_ipsecmb/CMakeLists.txt
index a6bb8dc7dcd..0d08032c07e 100644
--- a/src/plugins/crypto_ipsecmb/CMakeLists.txt
+++ b/src/plugins/crypto_ipsecmb/CMakeLists.txt
@@ -12,6 +12,10 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+if(NOT CMAKE_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
+ return()
+endif()
+
find_path(IPSECMB_INCLUDE_DIR NAMES intel-ipsec-mb.h HINTS ${IPSECMB_INCLUDE_DIR_HINT})
find_library(IPSECMB_LIB NAMES libIPSec_MB.a HINTS ${IPSECMB_LIB_DIR_HINT})
@@ -33,3 +37,5 @@ if(IPSECMB_INCLUDE_DIR AND IPSECMB_LIB)
else()
message(STATUS "Intel IPSecMB not found")
endif()
+
+target_compile_options(crypto_ipsecmb_plugin PRIVATE "-march=silvermont")