aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/crypto_native/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <dmarion@me.com>2020-02-12 10:59:14 +0100
committerNeale Ranns <nranns@cisco.com>2020-02-13 12:47:22 +0000
commit622b5ce61971066917cfba9ae795d9cb926f2700 (patch)
tree49ad66aaf27b10d17868bd45b0cc9fe1d4cbf98c /src/plugins/crypto_native/CMakeLists.txt
parent4e96ddaec8837b8c0bd27a75418e033da68e299b (diff)
crypto-native: add AArch64 AES-GCM native implementation
Type: feature Change-Id: I4f96b0af13b875d491704b010328a1814e1dbda1 Signed-off-by: Damjan Marion <dmarion@me.com>
Diffstat (limited to 'src/plugins/crypto_native/CMakeLists.txt')
-rw-r--r--src/plugins/crypto_native/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/crypto_native/CMakeLists.txt b/src/plugins/crypto_native/CMakeLists.txt
index 9ac29462815..c6d916ddbbd 100644
--- a/src/plugins/crypto_native/CMakeLists.txt
+++ b/src/plugins/crypto_native/CMakeLists.txt
@@ -26,7 +26,7 @@ endif()
if(CMAKE_SYSTEM_PROCESSOR MATCHES "^(aarch64.*|AARCH64.*)")
list(APPEND VARIANTS "armv8\;-march=armv8.1-a+crc+crypto")
- set (COMPILE_FILES aes_cbc.c)
+ set (COMPILE_FILES aes_cbc.c aes_gcm.c)
set (COMPILE_OPTS -Wall -fno-common)
endif()