aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/crypto_native/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2024-01-11 17:37:46 +0000
committerMohammed HAWARI <momohawari@gmail.com>2024-01-12 17:37:42 +0000
commitda3771c25bc30fb15c67f36393d975c46d313b60 (patch)
tree3d6f28b39d1eaa6320c7402f319dd3b6c1ba914f /src/plugins/crypto_native/CMakeLists.txt
parent9caef2a3518ee9a453adbb748a9f4799a5fbb56b (diff)
crypto-native: add AES-CTR
Type: feature Change-Id: Iab84226043d8042a99a507767b75e9d4a89cc5c6 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/plugins/crypto_native/CMakeLists.txt')
-rw-r--r--src/plugins/crypto_native/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/plugins/crypto_native/CMakeLists.txt b/src/plugins/crypto_native/CMakeLists.txt
index ba6f6cbcc28..9b6091610d9 100644
--- a/src/plugins/crypto_native/CMakeLists.txt
+++ b/src/plugins/crypto_native/CMakeLists.txt
@@ -23,13 +23,13 @@ if(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
if(compiler_flag_march_alderlake)
list(APPEND VARIANTS "adl\;-march=alderlake -mprefer-vector-width=256")
endif()
- set (COMPILE_FILES aes_cbc.c aes_gcm.c)
+ set (COMPILE_FILES aes_cbc.c aes_gcm.c aes_ctr.c)
set (COMPILE_OPTS -Wall -fno-common -maes)
endif()
if(CMAKE_SYSTEM_PROCESSOR MATCHES "^(aarch64.*|AARCH64.*)")
list(APPEND VARIANTS "armv8\;-march=armv8.1-a+crc+crypto")
- set (COMPILE_FILES aes_cbc.c aes_gcm.c)
+ set (COMPILE_FILES aes_cbc.c aes_gcm.c aes_ctr.c)
set (COMPILE_OPTS -Wall -fno-common)
endif()