aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/crypto_openssl/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2019-03-18 18:59:25 +0100
committerNeale Ranns <nranns@cisco.com>2019-03-19 16:29:43 +0000
commit91f17dc7c4e79343b8fba924e7cea6380a0e6653 (patch)
treea5c47649bcf8d6668dc509bbc6f7b67e45714784 /src/plugins/crypto_openssl/CMakeLists.txt
parent5daf0c55c094167ad590f683451239fa3e25c7fc (diff)
crypto: introduce crypto infra
Change-Id: Ibf320b3e7b054b686f3af9a55afd5d5bda9b1048 Signed-off-by: Damjan Marion <damarion@cisco.com> Signed-off-by: Filip Tehlar <ftehlar@cisco.com>
Diffstat (limited to 'src/plugins/crypto_openssl/CMakeLists.txt')
-rw-r--r--src/plugins/crypto_openssl/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/plugins/crypto_openssl/CMakeLists.txt b/src/plugins/crypto_openssl/CMakeLists.txt
new file mode 100644
index 00000000000..d014144eca8
--- /dev/null
+++ b/src/plugins/crypto_openssl/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+if(NOT OPENSSL_FOUND)
+ return()
+endif()
+
+include_directories(${OPENSSL_INCLUDE_DIR})
+
+add_vpp_plugin(crypto_openssl
+ SOURCES
+ main.c
+
+ LINK_LIBRARIES
+ ${OPENSSL_LIBRARIES}
+)