aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/dhcp/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-10-07 00:39:28 -0700
committerDave Barach <openvpp@barachs.net>2019-10-07 19:33:39 +0000
commit02bfd641b69aab83397e217b9ca4e35a6aab05c8 (patch)
tree665e232425f90d0662bc3d29729e11bb5e8727fc /src/plugins/dhcp/CMakeLists.txt
parent2c41a61d5fc87737b9b46b88cb9271d0f987721e (diff)
dhcp: Move to plugin
Type: feature Change-Id: I3fe27a8ef577741d9a5c4f090ec91cf68fb44fe3 Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/dhcp/CMakeLists.txt')
-rw-r--r--src/plugins/dhcp/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/plugins/dhcp/CMakeLists.txt b/src/plugins/dhcp/CMakeLists.txt
new file mode 100644
index 00000000000..b2dd630d461
--- /dev/null
+++ b/src/plugins/dhcp/CMakeLists.txt
@@ -0,0 +1,51 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(dhcp
+ SOURCES
+ client.c
+ dhcp_api.c
+ dhcp_client_detect.c
+ dhcp_proxy.c
+ dhcp4_proxy_node.c
+ dhcp6_client_common_dp.c
+ dhcp6_ia_na_client_dp.c
+ dhcp6_ia_na_client_cp.c
+ dhcp6_ia_na_client_cp_api.c
+ dhcp6_pd_client_cp.c
+ dhcp6_pd_client_cp_api.c
+ dhcp6_pd_client_dp.c
+ dhcp6_proxy_node.c
+
+ MULTIARCH_SOURCES
+ dhcp_client_detect.c
+
+ API_FILES
+ dhcp.api
+ dhcp6_pd_client_cp.api
+ dhcp6_ia_na_client_cp.api
+
+ INSTALL_HEADERS
+ client.h
+ dhcp4_packet.h
+ dhcp6_packet.h
+ dhcp_proxy.h
+ dhcp6_proxy_error.def
+ dhcp4_proxy_error.def
+ dhcp6_client_common_dp.h
+ dhcp6_pd_client_dp.h
+ dhcp6_ia_na_client_dp.h
+
+ API_TEST_SOURCES
+ dhcp_test.c
+)