aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/dhcp/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-10-15 15:47:55 +0000
committerNeale Ranns <nranns@cisco.com>2019-10-25 17:56:06 +0000
commit6bcc6a45573f387fa6c1682069da7ee9036cabe2 (patch)
tree2471089b417624c5eeda998db113edeb5b4b5c95 /src/plugins/dhcp/CMakeLists.txt
parentd7b306657d205fddd781e982aec5f3c3dc69fa88 (diff)
dhcp: fix crash on unicast renewal send
Type: fix - when the addresses were learnt a copy of the client was sent to the main thread, this meant the unicast adjacecny was saved on the copy not on the original. - Add logging. - Improve the proxy-node that hands the clint packets so the DHCP packets are traced. - allow a renewal to configure new address data Change-Id: I6ab0afcccbc4a1cdefdd1b8beeda8fc7ba20ec1f Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/dhcp/CMakeLists.txt')
-rw-r--r--src/plugins/dhcp/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/dhcp/CMakeLists.txt b/src/plugins/dhcp/CMakeLists.txt
index b2dd630d461..9db38e391f6 100644
--- a/src/plugins/dhcp/CMakeLists.txt
+++ b/src/plugins/dhcp/CMakeLists.txt
@@ -17,6 +17,7 @@ add_vpp_plugin(dhcp
dhcp_api.c
dhcp_client_detect.c
dhcp_proxy.c
+ dhcp4_packet.c
dhcp4_proxy_node.c
dhcp6_client_common_dp.c
dhcp6_ia_na_client_dp.c