aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/dns/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-08-21 19:23:00 -0400
committerFlorin Coras <florin.coras@gmail.com>2019-08-22 15:05:49 +0000
commit34af0ccf5cf27d8a72119626d2d009222e4ff0a6 (patch)
treeab108d50c4b59de2122dd5f6cd8f06f3543a2b47 /src/plugins/dns/CMakeLists.txt
parent2ca9a84bd00f2aee642d0147c1b99d4be5725a70 (diff)
dns: make the dns name resolver a plugin
Type: refactor Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I823c2cd307a4613653a2d20f564dda062d4da31b
Diffstat (limited to 'src/plugins/dns/CMakeLists.txt')
-rw-r--r--src/plugins/dns/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/plugins/dns/CMakeLists.txt b/src/plugins/dns/CMakeLists.txt
new file mode 100644
index 00000000000..5d1ac8628db
--- /dev/null
+++ b/src/plugins/dns/CMakeLists.txt
@@ -0,0 +1,33 @@
+
+# Copyright (c) <current-year> <your-organization>
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(dns
+ SOURCES
+ dns.c
+ dns.h
+ request_node.c
+ reply_node.c
+ resolver_process.c
+
+ API_FILES
+ dns.api
+
+ INSTALL_HEADERS
+ dns_all_api_h.h
+ dns_msg_enum.h
+ dns_packet.h
+
+ API_TEST_SOURCES
+ dns_test.c
+)