aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/dpdk/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Smith <mgsmith@netgate.com>2019-04-01 18:38:59 -0500
committerDamjan Marion <dmarion@me.com>2019-04-02 06:55:11 +0000
commit72491e2a17620d06ec72d49c008e31b7c8e16c98 (patch)
treeb40e637e876bfb19ab33777821aafaecaaba53ad /src/plugins/dpdk/CMakeLists.txt
parentd1a12ef820608516d6b9f76fe0e4ad8c7a04629c (diff)
dpdk: fix build error when mlx support enabled
When building with environment variables set to enable mlx PMD support in DPDK, an error occurs: CMake Error at plugins/dpdk/CMakeLists.txt:104 (vpp_plugin_find_library): vpp_plugin_find_library Macro invoked with incorrect arguments for macro named: vpp_plugin_find_library Update a call to vpp_plugin_find_library() to include the right number of parameters. Change-Id: Ia0d66f93c6f94fdf822e2c3c4fe3f0ad01a90d57 Signed-off-by: Matthew Smith <mgsmith@netgate.com>
Diffstat (limited to 'src/plugins/dpdk/CMakeLists.txt')
-rw-r--r--src/plugins/dpdk/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/dpdk/CMakeLists.txt b/src/plugins/dpdk/CMakeLists.txt
index 76b22a9704c..1818adaea61 100644
--- a/src/plugins/dpdk/CMakeLists.txt
+++ b/src/plugins/dpdk/CMakeLists.txt
@@ -101,7 +101,7 @@ endif()
# Mellanox libraries
##############################################################################
if(DPDK_RTE_LIBRTE_MLX4_PMD OR DPDK_RTE_LIBRTE_MLX5_PMD)
- vpp_plugin_find_library(MNL_LIB "mnl")
+ vpp_plugin_find_library(dpdk MNL_LIB "mnl")
list(APPEND DPDK_LINK_LIBRARIES "${MNL_LIB}")
if (DPDK_RTE_IBVERBS_LINK_DLOPEN)
message(STATUS "DPDK depends on libmnl (Mellanox PMD requirement)")