aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/dpdk/CMakeLists.txt
diff options
context:
space:
mode:
authorMohammed Hawari <mohammed@hawari.fr>2021-04-20 10:05:52 +0200
committerMohammed Hawari <mohammed@hawari.fr>2021-04-20 10:08:36 +0200
commit94761f6d427cc2bb01f37ba0ad46989869a5b436 (patch)
treedbc5fae43c4264a3af5ef8f3ac9360ff6e1ee390 /src/plugins/dpdk/CMakeLists.txt
parent5b6f3dad9b05f21c31fe4b400e357feebd7792eb (diff)
dpdk: fix mlx4 mlx5 detection in plugin build
Since the move to DPDK 21.02, compatibility build symbols were depreca- ted, breaking the static linkage of the DPDK plugin to libibverbs. Change-Id: I2fec0807e4c0eb00268618f1495af862eede9081 Type: fix Fixes: 5f35a185d5afee2c364fe84f33922bac1a808113 Signed-off-by: Mohammed Hawari <mohammed@hawari.fr>
Diffstat (limited to 'src/plugins/dpdk/CMakeLists.txt')
-rw-r--r--src/plugins/dpdk/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/dpdk/CMakeLists.txt b/src/plugins/dpdk/CMakeLists.txt
index 9655daf8f8d..8650841293e 100644
--- a/src/plugins/dpdk/CMakeLists.txt
+++ b/src/plugins/dpdk/CMakeLists.txt
@@ -96,7 +96,7 @@ else()
##############################################################################
# Mellanox libraries
##############################################################################
- if(DPDK_RTE_LIBRTE_MLX4_PMD OR DPDK_RTE_LIBRTE_MLX5_PMD)
+ if(DPDK_RTE_NET_MLX4 OR DPDK_RTE_NET_MLX5)
if (DPDK_RTE_IBVERBS_LINK_DLOPEN)
message(STATUS "DPDK depends on libmnl (Mellanox PMD requirement)")
vpp_plugin_find_library(dpdk MNL_LIB "mnl")