aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/gre/CMakeLists.txt
diff options
context:
space:
mode:
authorChuhao Tang <nicotang@cisco.com>2023-04-27 15:43:42 +0200
committerBeno�t Ganne <bganne@cisco.com>2023-05-12 06:59:09 +0000
commitcefb178aa487a217d4ac75d7d4fa62db4b7d70fd (patch)
treeaeacf10d2387eeb3564ac42cacae17679d060e6c /src/plugins/gre/CMakeLists.txt
parent683bdb6743e0568bbf02c1f4953d3f73e6f2b544 (diff)
gre: move to a plugin
Move GRE folder under vnet to the plugin folder, and modify some of path of the #inlude<header> to the new path. Add a plugin.c file to register a plugin. JIRA: VPP-2044 Type: improvement Change-Id: I7f64cecd97538a7492e56a41558dab58281a9fa5 Signed-off-by: Chuhao Tang <nicotang@cisco.com>
Diffstat (limited to 'src/plugins/gre/CMakeLists.txt')
-rw-r--r--src/plugins/gre/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/plugins/gre/CMakeLists.txt b/src/plugins/gre/CMakeLists.txt
new file mode 100644
index 00000000000..60fe540b968
--- /dev/null
+++ b/src/plugins/gre/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright (c) 2023 Cisco and/or its affiliates
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(gre
+ SOURCES
+ gre.c
+ node.c
+ gre_api.c
+ interface.c
+ pg.c
+ plugin.c
+
+ MULTIARCH_SOURCES
+ node.c
+ gre.c
+
+ INSTALL_HEADERS
+ gre.h
+ error.def
+
+ API_FILES
+ gre.api
+
+)
+