aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/hs_apps/CMakeLists.txt
diff options
context:
space:
mode:
authorMatus Fabian <matfabia@cisco.com>2024-06-27 13:20:10 +0200
committerFlorin Coras <florin.coras@gmail.com>2024-07-23 20:37:16 +0000
commitd086a3650eea95056e738e2cc5dc18ce6edc278b (patch)
tree4dcb6d843b01143ab76428c268b6e382c6694545 /src/plugins/hs_apps/CMakeLists.txt
parent8ca6ce6fe1e65c8b57b9c0910dfd1243db0e49b9 (diff)
http: state machine fix
When client sends second request without waiting for response of the first request http_ts_rx_callback should drop request (pipelining is not supported) instead of invoking return to state machine which can lead to erroneous state, e.g. reading random data from server app fifo. Added simple http static server url handler for testing to simulate long running request processing, for now hardcoded delay 5 seconds. Type: fix Change-Id: Ied9f7e2e4ee64c982f045c0f7f99a2dc5d7a2108 Signed-off-by: Matus Fabian <matfabia@cisco.com>
Diffstat (limited to 'src/plugins/hs_apps/CMakeLists.txt')
-rw-r--r--src/plugins/hs_apps/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/hs_apps/CMakeLists.txt b/src/plugins/hs_apps/CMakeLists.txt
index 179c9c7a4c4..3553a25837e 100644
--- a/src/plugins/hs_apps/CMakeLists.txt
+++ b/src/plugins/hs_apps/CMakeLists.txt
@@ -23,6 +23,7 @@ add_vpp_plugin(hs_apps
http_client_cli.c
http_tps.c
proxy.c
+ test_builtins.c
)
##############################################################################