aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/hs_apps/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2019-06-24 17:31:33 -0700
committerDave Wallace <dwallacelf@gmail.com>2019-06-25 14:25:54 +0000
commite3b8682d3f180a89ef7c37a7387adbfa088013b9 (patch)
tree73d21de5aea169801dd6a074a91be8e550539ef3 /src/plugins/hs_apps/CMakeLists.txt
parent1b534f5a4ad33f78159113f5a922465df6b32cef (diff)
hsa: move session-apps to host-stack apps plugin
Type:refactor Change-Id: I114fea3a54258797e961d8627a99ba2098674d20 Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'src/plugins/hs_apps/CMakeLists.txt')
-rw-r--r--src/plugins/hs_apps/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/plugins/hs_apps/CMakeLists.txt b/src/plugins/hs_apps/CMakeLists.txt
new file mode 100644
index 00000000000..d27c8512306
--- /dev/null
+++ b/src/plugins/hs_apps/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (c) 2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(hs_apps
+ SOURCES
+ echo_client.c
+ echo_server.c
+ hs_apps.c
+ http_server.c
+ proxy.c
+)