aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/ikev2/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-02-25 10:28:29 +0000
committerDamjan Marion <dmarion@me.com>2019-02-25 19:37:09 +0000
commit7c44d78ef2e7bf0c8714be4184511ed8f23ff239 (patch)
treeb09f294ebe6365bd38ed0dc7ef4c696cd7630de0 /src/plugins/ikev2/CMakeLists.txt
parentf883f6a1132ad4bb7aa9d9a79d420274fbcf3b64 (diff)
IKEv2 to plugin
for easy integration with ptoducts running their own Ike stack. Without the VPP IKE plugin loaded, the product is free to handle IKE packets as it pleases. Change-Id: Id0839f4d58b797f4c2da0382eb499fc08b05f66f Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/ikev2/CMakeLists.txt')
-rw-r--r--src/plugins/ikev2/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/plugins/ikev2/CMakeLists.txt b/src/plugins/ikev2/CMakeLists.txt
new file mode 100644
index 00000000000..800b9a8d67e
--- /dev/null
+++ b/src/plugins/ikev2/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(ikev2
+ SOURCES
+ ikev2.c
+ ikev2_api.c
+ ikev2_cli.c
+ ikev2_crypto.c
+ ikev2_format.c
+ ikev2_payload.c
+
+ API_FILES
+ ikev2.api
+
+ API_TEST_SOURCES
+ ikev2_test.c
+
+ INSTALL_HEADERS
+ ikev2.h
+ ikev2_priv.h
+
+ COMPONENT vpp-plugin-ikev2
+)