aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/l2tp/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2020-09-18 14:05:45 +0000
committerOle Tr�an <otroan@employees.org>2020-09-21 17:03:52 +0000
commit6810a77da36c6750938800314c15e840ee2a8c93 (patch)
tree8527e0fc312e0d3ad21ef6a6579e3b784f53ffc6 /src/plugins/l2tp/CMakeLists.txt
parent3f9fdd98463bd926fc78a2b366875c929058e2db (diff)
misc: Move l2tp to plugin
Type: refactor Change-Id: Ifb36eeb146b87e9e305881429d32d6879e955e1e Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/l2tp/CMakeLists.txt')
-rw-r--r--src/plugins/l2tp/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/plugins/l2tp/CMakeLists.txt b/src/plugins/l2tp/CMakeLists.txt
new file mode 100644
index 00000000000..c8261abcd9c
--- /dev/null
+++ b/src/plugins/l2tp/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+##############################################################################
+# Tunnel protocol: l2tpv3
+##############################################################################
+add_vpp_plugin(l2tp
+ SOURCES
+ l2tp.c
+ encap.c
+ decap.c
+ pg.c
+ l2tp_api.c
+
+ MULTIARCH_SOURCES
+ encap.c
+ decap.c
+
+ INSTALL_HEADERS
+ l2tp.h
+ packet.h
+
+ API_FILES
+ l2tp.api
+
+ API_TEST_SOURCES
+ l2tp_test.c
+)