aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/l3xc/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-05-22 13:26:39 +0000
committerDamjan Marion <dmarion@me.com>2019-06-05 11:33:12 +0000
commit59fa121f8953f7b07f0cc02149ca28182f959f42 (patch)
tree51249a3bf2da047a791b7446af09f15df91118a6 /src/plugins/l3xc/CMakeLists.txt
parente6be702362299566990678f505512b1b74b49112 (diff)
L3 cross connect
- all packets input on interface X are load-balanced over the set of paths provided. Change-Id: Ic27cb88c4cd5d6d3462570632daff7a43d5a652d Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/l3xc/CMakeLists.txt')
-rw-r--r--src/plugins/l3xc/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/plugins/l3xc/CMakeLists.txt b/src/plugins/l3xc/CMakeLists.txt
new file mode 100644
index 00000000000..82ea08404d9
--- /dev/null
+++ b/src/plugins/l3xc/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(l3xc
+ SOURCES
+ l3xc.c
+ l3xc_api.c
+ l3xc_node.c
+
+ API_FILES
+ l3xc.api
+
+ INSTALL_HEADERS
+ l3xc_all_api_h.h
+ l3xc_msg_enum.h
+)