aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/lb/CMakeLists.txt
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2019-06-10 19:43:48 +0800
committerAndrew Yourtchenko <ayourtch@gmail.com>2019-07-31 19:35:13 +0000
commit3efcd0d7c3e73b812dece730396cf8816951d8ad (patch)
treebe6ea249ce63f3595c1271ba8e005881e02b9d86 /src/plugins/lb/CMakeLists.txt
parent515eed42583a52d4783ff4906afa01244899e030 (diff)
lb: vip and as dump/detail api's
- lb_vip_dump/lb_vip_details - get all vip. - lb_as_dump/lb_as_details - get all as list per vip. - adds api unit test. - adds vpp_lb to test framework. Ticket: Type: feature Change-Id: I24be50d62c5234f3535cc840603ddd9df7eb3f07 Signed-off-by: Hongjun Ni <hongjun.ni@intel.com> Signed-off-by: Paul Vinciguerra <pvinci@vinciconsulting.com> Signed-off-by: Hongjun Ni <hongjun.ni@intel.com>
Diffstat (limited to 'src/plugins/lb/CMakeLists.txt')
-rw-r--r--src/plugins/lb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/lb/CMakeLists.txt b/src/plugins/lb/CMakeLists.txt
index 406b16a9fe2..69ca948a001 100644
--- a/src/plugins/lb/CMakeLists.txt
+++ b/src/plugins/lb/CMakeLists.txt
@@ -21,6 +21,7 @@ add_vpp_plugin(lb
API_FILES
lb.api
+ lb_types.api
INSTALL_HEADERS
lb.h