aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/linux-cp/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2020-12-24 09:16:09 +0000
committerOle Tr�an <otroan@employees.org>2021-02-04 14:16:34 +0000
commit44db1caefbf5067b0cf0073299c9f21265331412 (patch)
tree4981dc028db66398cf6dc2ca9d309aa5a7bf7a1d /src/plugins/linux-cp/CMakeLists.txt
parent1a52d37fc50acd479274c29c2e92b05cf32c3a6d (diff)
linux-cp: Linux Interface Mirroring for Control Plane Integration
Type: feature please see FEATURE.yaml for details. Signed-off-by: Neale Ranns <nranns@cisco.com> Signed-off-by: Matthew Smith <mgsmith@netgate.com> Signed-off-by: Jon Loeliger <jdl@netgate.com> Signed-off-by: Pim van Pelt <pim@ipng.nl> Change-Id: I04a45c15c0838906aa787e06660fa29f39f755fa
Diffstat (limited to 'src/plugins/linux-cp/CMakeLists.txt')
-rw-r--r--src/plugins/linux-cp/CMakeLists.txt61
1 files changed, 61 insertions, 0 deletions
diff --git a/src/plugins/linux-cp/CMakeLists.txt b/src/plugins/linux-cp/CMakeLists.txt
new file mode 100644
index 00000000000..6b6ccb3d0b1
--- /dev/null
+++ b/src/plugins/linux-cp/CMakeLists.txt
@@ -0,0 +1,61 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+find_path(LIBNL3_INCLUDE_DIR NAMES libnl3/netlink/route/link/vlan.h)
+
+if (NOT LIBNL3_INCLUDE_DIR)
+ message(WARNING "-- libnl3 headers not found - linux-cp plugin disabled")
+ return()
+endif()
+
+vpp_plugin_find_library(linux-cp LIBNL3_LIB libnl-3.so)
+vpp_plugin_find_library(linux-cp LIBNL3_ROUTE_LIB libnl-route-3.so.200)
+
+include_directories(${LIBNL3_INCLUDE_DIR}/libnl3)
+include_directories(${LIBMNL_INCLUDE_DIR})
+
+add_vpp_library(lcp
+ SOURCES
+ lcp_interface.c
+ lcp_adj.c
+ lcp.c
+
+ LINK_LIBRARIES
+ ${LIBNL3_LIB}
+ ${LIBNL3_ROUTE_LIB}
+
+ INSTALL_HEADERS
+ lcp_interface.h
+ lcp.h
+)
+
+add_vpp_plugin(linux_cp
+ SOURCES
+ lcp_api.c
+ lcp_cli.c
+ lcp_node.c
+
+ API_FILES
+ lcp.api
+
+ LINK_LIBRARIES
+ lcp
+)
+
+add_vpp_plugin(linux_cp_unittest
+ SOURCES
+ test/lcp_unittest.c
+
+ LINK_LIBRARIES
+ lcp
+)