aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/lldp/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2020-09-18 12:58:40 +0000
committerOle Tr�an <otroan@employees.org>2020-09-21 15:34:56 +0000
commit3f9fdd98463bd926fc78a2b366875c929058e2db (patch)
treea38c26372ed7b1a433afbacf05e686044f1cf583 /src/plugins/lldp/CMakeLists.txt
parent4b1b13315a3c532d45fb41cc3ce34a48ad72a757 (diff)
lldp: Move to plugin
Type: refactor Change-Id: Ifd770ff4850e63474bf4682ad463021b03786b4b Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/lldp/CMakeLists.txt')
-rw-r--r--src/plugins/lldp/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/plugins/lldp/CMakeLists.txt b/src/plugins/lldp/CMakeLists.txt
new file mode 100644
index 00000000000..98df0bb0199
--- /dev/null
+++ b/src/plugins/lldp/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+
+add_vpp_plugin(lldp
+ SOURCES
+ lldp_input.c
+ lldp_node.c
+ lldp_output.c
+ lldp_cli.c
+ lldp_api.c
+
+ API_FILES
+ lldp.api
+
+ INSTALL_HEADERS
+ lldp_protocol.h
+ lldp.h
+
+ API_TEST_SOURCES
+ lldp_test.c
+)