aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/mactime/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-10-07 12:04:31 -0400
committerFlorin Coras <florin.coras@gmail.com>2019-10-07 17:46:16 +0000
commit2c41a61d5fc87737b9b46b88cb9271d0f987721e (patch)
tree6ef31361cdc9d55f1be3c9d939f2a2a8c0f6a586 /src/plugins/mactime/CMakeLists.txt
parent0eb75d0e9c7624a4e8ac69fea7dbe12d39b75096 (diff)
mactime: add a "top" command to watch device stats
Include a binary API change NOT suitable for cherry-picking into 19.08 Type: feature Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: Id369514a3085f5e4bcee34819c55c4636df9b518
Diffstat (limited to 'src/plugins/mactime/CMakeLists.txt')
-rw-r--r--src/plugins/mactime/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/plugins/mactime/CMakeLists.txt b/src/plugins/mactime/CMakeLists.txt
index ac5077d1860..5477674f22a 100644
--- a/src/plugins/mactime/CMakeLists.txt
+++ b/src/plugins/mactime/CMakeLists.txt
@@ -22,3 +22,21 @@ add_vpp_plugin(mactime
API_TEST_SOURCES
mactime_test.c
)
+
+option(VPP_BUILD_MACTIME_TOP "Build mactime plugin 'top' tool" OFF)
+if(VPP_BUILD_MACTIME_TOP)
+ add_vpp_executable(mactime_top ENABLE_EXPORTS
+ SOURCES
+ mactime_top.c
+
+ DEPENDS api_headers
+
+ LINK_LIBRARIES
+ vlibmemoryclient
+ vppapiclient
+ svm
+ vppinfra
+ Threads::Threads
+ rt m dl crypto
+ )
+endif()