aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/map/CMakeLists.txt
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2018-12-18 12:33:26 +0100
committerDamjan Marion <dmarion@me.com>2018-12-18 13:02:45 +0000
commit91bfa6e2666c56f79cc97407c929d188cb34e90f (patch)
tree47eb4d66b08e0f93ba2218a8a24116daee80e78d /src/plugins/map/CMakeLists.txt
parent9e829a856fdf88b3ea5770048ea20dcd50d1b4eb (diff)
MAP: Add longest matching prefix (LPM) data structures
In preparation for adding input feature MAP support, as opposed to going via the FIB, add MAP's own LPM data structures. Change-Id: Ie363f0961b0ac9dde2a0fb76cb0c58c904876974 Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'src/plugins/map/CMakeLists.txt')
-rw-r--r--src/plugins/map/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/map/CMakeLists.txt b/src/plugins/map/CMakeLists.txt
index 20d5dfebbe6..2d604e6e4d8 100644
--- a/src/plugins/map/CMakeLists.txt
+++ b/src/plugins/map/CMakeLists.txt
@@ -20,6 +20,7 @@ add_vpp_plugin(map
map_api.c
map.c
map_dpo.c
+ lpm.c
API_FILES
map.api