aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/marvell/CMakeLists.txt
diff options
context:
space:
mode:
authorJianlin Lv <Jianlin.Lv@arm.com>2019-09-27 09:35:41 +0800
committerDamjan Marion <dmarion@me.com>2019-10-07 20:22:00 +0000
commit859b59133c143b09fed86af1d409d320fa45424f (patch)
treef06e0a48070ce080c893f8b673574d5addacf586 /src/plugins/marvell/CMakeLists.txt
parent3a1ef47c39eacdb2177cedca48db543d1c514f9c (diff)
api: Add API support for marvell PP2 plugin
Support create/delete interface with PP2 api Type: feature Signed-off-by: Jianlin Lv <Jianlin.Lv@arm.com> Change-Id: Ia9c0ac0f237fd9f71f5480d736d6bcabee763fff
Diffstat (limited to 'src/plugins/marvell/CMakeLists.txt')
-rw-r--r--src/plugins/marvell/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/plugins/marvell/CMakeLists.txt b/src/plugins/marvell/CMakeLists.txt
index 4e4b76886fa..336d4d6c4a3 100644
--- a/src/plugins/marvell/CMakeLists.txt
+++ b/src/plugins/marvell/CMakeLists.txt
@@ -29,6 +29,13 @@ if(MUSDK_INCLUDE_DIR AND MUSDK_LIB)
pp2/input.c
pp2/output.c
pp2/pp2.c
+ pp2/pp2_api.c
+
+ API_FILES
+ pp2/pp2.api
+
+ API_TEST_SOURCES
+ pp2/pp2_test.c
LINK_FLAGS
${MUSDK_LINK_FLAGS}