aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/mdata/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-10-24 18:10:10 -0400
committerDave Barach <openvpp@barachs.net>2019-10-25 14:36:13 +0000
commitd7b306657d205fddd781e982aec5f3c3dc69fa88 (patch)
tree20f61a92fb05cfcc727bb4a95977a306a8d7a614 /src/plugins/mdata/CMakeLists.txt
parent94afc9391d0588608d67de717a927e9a50349d3a (diff)
mdata: buffer metadata change tracker plugin
A handy tool in case you need to know which metadata will be changed when a packet visits a certain node. Reflect metadata changes into format functions used by the vpp-specific wireshark dissector. Type: feature Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I96fe8a24db4082bb29fe2a33cc522e8616a3a1bb
Diffstat (limited to 'src/plugins/mdata/CMakeLists.txt')
-rw-r--r--src/plugins/mdata/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/plugins/mdata/CMakeLists.txt b/src/plugins/mdata/CMakeLists.txt
new file mode 100644
index 00000000000..6f45281e2b3
--- /dev/null
+++ b/src/plugins/mdata/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Copyright (c) 2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(mdata
+ SOURCES
+ mdata.c
+ mdata.h
+
+ API_FILES
+ mdata.api
+
+ API_TEST_SOURCES
+ mdata_test.c
+)