aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nat/CMakeLists.txt
diff options
context:
space:
mode:
authorFilip Varga <fivarga@cisco.com>2021-02-17 14:34:54 +0100
committerOle Tr�an <otroan@employees.org>2021-02-24 19:25:25 +0000
commit0eaf4e6784efb2d058fe2f031578251b6bcc0aa8 (patch)
treecc0c2b485bfee51068fa4970acc9f95ec595e8e5 /src/plugins/nat/CMakeLists.txt
parent5db2f4a4312112ab57043ce88f10edc4acc141ec (diff)
nat: Final NAT44 EI/ED split patch
This patch achieves complete separation of endpoint-dependent and endpoint-independent IPv4 NAT features. Some common stuff is also moved to NAT library. Type: refactor Change-Id: I52468b7e2b5ac28958a2baf8e2ea01787322e801 Signed-off-by: Filip Varga <fivarga@cisco.com>
Diffstat (limited to 'src/plugins/nat/CMakeLists.txt')
-rw-r--r--src/plugins/nat/CMakeLists.txt59
1 files changed, 38 insertions, 21 deletions
diff --git a/src/plugins/nat/CMakeLists.txt b/src/plugins/nat/CMakeLists.txt
index 8fefadf0dd1..623c92ace69 100644
--- a/src/plugins/nat/CMakeLists.txt
+++ b/src/plugins/nat/CMakeLists.txt
@@ -18,43 +18,60 @@ add_vpp_library(nat
lib/ipfix_logging.c
lib/nat_syslog.c
lib/alloc.c
+ lib/lib.c
INSTALL_HEADERS
lib/ipfix_logging.h
lib/nat_syslog.h
lib/alloc.h
+ lib/lib.h
)
add_vpp_plugin(nat
SOURCES
- nat.c
- nat44_api.c
- in2out_ed.c
- out2in_ed.c
- nat_dpo.c
- nat44_cli.c
- nat44_handoff.c
- nat44_hairpinning.c
- nat44_classify.c
- nat_affinity.c
- nat_format.c
+ nat44-ed/nat44_ed.c
+ nat44-ed/nat44_ed_api.c
+ nat44-ed/nat44_ed_in2out.c
+ nat44-ed/nat44_ed_out2in.c
+ nat44-ed/nat44_ed_cli.c
+ nat44-ed/nat44_ed_format.c
+ nat44-ed/nat44_ed_affinity.c
+ nat44-ed/nat44_ed_handoff.c
+ nat44-ed/nat44_ed_classify.c
+
+ MULTIARCH_SOURCES
+ nat44-ed/nat44_ed_in2out.c
+ nat44-ed/nat44_ed_out2in.c
+ nat44-ed/nat44_ed_handoff.c
+ nat44-ed/nat44_ed_classify.c
+
+ API_FILES
+ nat44-ed/nat44_ed.api
+ lib/nat_types.api
+
+ LINK_LIBRARIES nat
+)
+
+add_vpp_plugin(nat44_ei
+ SOURCES
nat44-ei/nat44_ei.c
nat44-ei/nat44_ei_ha.c
+ nat44-ei/nat44_ei_cli.c
+ nat44-ei/nat44_ei_api.c
+ nat44-ei/nat44_ei_dpo.c
nat44-ei/nat44_ei_in2out.c
nat44-ei/nat44_ei_out2in.c
+ nat44-ei/nat44_ei_handoff.c
+ nat44-ei/nat44_ei_hairpinning.c
MULTIARCH_SOURCES
- in2out_ed.c
- out2in_ed.c
- nat44_classify.c
- nat44_hairpinning.c
- nat44_handoff.c
nat44-ei/nat44_ei_in2out.c
nat44-ei/nat44_ei_out2in.c
+ nat44-ei/nat44_ei_hairpinning.c
API_FILES
- nat44.api
- nat_types.api
+ nat44-ei/nat44_ei.api
+ lib/nat_types.api
LINK_LIBRARIES nat
)
@@ -96,7 +113,7 @@ add_vpp_plugin(nat66
API_FILES
nat66/nat66.api
- nat_types.api
+ lib/nat_types.api
LINK_LIBRARIES nat
)
@@ -115,7 +132,7 @@ add_vpp_plugin(det44
API_FILES
det44/det44.api
- nat_types.api
+ lib/nat_types.api
LINK_LIBRARIES nat
)
@@ -135,7 +152,7 @@ add_vpp_plugin(nat64
API_FILES
nat64/nat64.api
- nat_types.api
+ lib/nat_types.api
LINK_LIBRARIES nat
)