aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nat/CMakeLists.txt
diff options
context:
space:
mode:
authorFilip Varga <fivarga@cisco.com>2020-09-14 11:20:16 +0200
committerOle Tr�an <otroan@employees.org>2020-10-07 09:05:50 +0000
commit1f36023d29137825b8a09578d09b955046c2415b (patch)
treec00726718d9d8b4f5ecc74c45d9a2d790deb0250 /src/plugins/nat/CMakeLists.txt
parentd1762e614d1e05cbeda4d91e921fa663b2b46c03 (diff)
nat: move nat64 to a subfeature
Type: refactor Change-Id: I3b9e17164647d2019b1f40cffeed63393345219e Signed-off-by: Filip Varga <fivarga@cisco.com>
Diffstat (limited to 'src/plugins/nat/CMakeLists.txt')
-rw-r--r--src/plugins/nat/CMakeLists.txt28
1 files changed, 21 insertions, 7 deletions
diff --git a/src/plugins/nat/CMakeLists.txt b/src/plugins/nat/CMakeLists.txt
index 688eb4f1207..727f57904af 100644
--- a/src/plugins/nat/CMakeLists.txt
+++ b/src/plugins/nat/CMakeLists.txt
@@ -35,11 +35,6 @@ add_vpp_plugin(nat
nat44_handoff.c
nat44_hairpinning.c
nat44_classify.c
- nat64.c
- nat64_cli.c
- nat64_in2out.c
- nat64_out2in.c
- nat64_db.c
nat_affinity.c
nat_format.c
nat_syslog.c
@@ -51,8 +46,6 @@ add_vpp_plugin(nat
nat44_classify.c
nat44_hairpinning.c
nat44_handoff.c
- nat64_in2out.c
- nat64_out2in.c
out2in.c
out2in_ed.c
@@ -130,3 +123,24 @@ add_vpp_plugin(det44
LINK_LIBRARIES nat
)
+
+add_vpp_plugin(nat64
+ SOURCES
+ nat_syslog.c
+ nat64/nat64.c
+ nat64/nat64_db.c
+ nat64/nat64_cli.c
+ nat64/nat64_api.c
+ nat64/nat64_in2out.c
+ nat64/nat64_out2in.c
+
+ MULTIARCH_SOURCES
+ nat64/nat64_in2out.c
+ nat64/nat64_out2in.c
+
+ API_FILES
+ nat64/nat64.api
+ nat_types.api
+
+ LINK_LIBRARIES nat
+)