aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nat/CMakeLists.txt
diff options
context:
space:
mode:
authorFilip Varga <fivarga@cisco.com>2020-07-21 10:27:39 +0200
committerOle Trøan <otroan@employees.org>2020-08-13 10:06:33 +0000
commit603e75465899385a95350f3c96499050f7f960a5 (patch)
treef7a7130769ea795c1c3460db3aea99a49a309b13 /src/plugins/nat/CMakeLists.txt
parentde118da58e80aec43f4b816a1ea957634a8bc07c (diff)
nat: move deterministic nat to det44 sub feature
Type: refactor Change-Id: I0bb203102a0e13dd7448e2125925ab356bbd7937 Signed-off-by: Filip Varga <fivarga@cisco.com>
Diffstat (limited to 'src/plugins/nat/CMakeLists.txt')
-rw-r--r--src/plugins/nat/CMakeLists.txt24
1 files changed, 19 insertions, 5 deletions
diff --git a/src/plugins/nat/CMakeLists.txt b/src/plugins/nat/CMakeLists.txt
index 5ce8b8a3273..688eb4f1207 100644
--- a/src/plugins/nat/CMakeLists.txt
+++ b/src/plugins/nat/CMakeLists.txt
@@ -30,9 +30,6 @@ add_vpp_plugin(nat
out2in.c
out2in_ed.c
nat_ipfix_logging.c
- nat_det.c
- nat_det_in2out.c
- nat_det_out2in.c
nat_dpo.c
nat44_cli.c
nat44_handoff.c
@@ -56,8 +53,6 @@ add_vpp_plugin(nat
nat44_handoff.c
nat64_in2out.c
nat64_out2in.c
- nat_det_in2out.c
- nat_det_out2in.c
out2in.c
out2in_ed.c
@@ -116,3 +111,22 @@ add_vpp_plugin(nat66
LINK_LIBRARIES nat
)
+
+add_vpp_plugin(det44
+ SOURCES
+ det44/det44.c
+ det44/det44_cli.c
+ det44/det44_api.c
+ det44/det44_in2out.c
+ det44/det44_out2in.c
+
+ MULTIARCH_SOURCES
+ det44/det44_in2out.c
+ det44/det44_out2in.c
+
+ API_FILES
+ det44/det44.api
+ nat_types.api
+
+ LINK_LIBRARIES nat
+)