aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nat/CMakeLists.txt
diff options
context:
space:
mode:
authorFilip Varga <fivarga@cisco.com>2020-01-16 14:58:47 +0100
committerOle Trøan <otroan@employees.org>2020-01-17 13:20:15 +0000
commit720435d03531da68e18c2a0dc867aa99d2daced6 (patch)
treebe07870046198dca861b23631ca489433753cf3f /src/plugins/nat/CMakeLists.txt
parent13e6fce7c5b3a16a6af0b27fc259ef3f65d8c861 (diff)
nat: refactor of port/address allocation functions
Change-Id: Ie2a3c0f44322dd8415603b7ce51bb72d72769c95 Ticket: VPP-1815 Type: refactor Signed-off-by: Filip Varga <fivarga@cisco.com>
Diffstat (limited to 'src/plugins/nat/CMakeLists.txt')
-rw-r--r--src/plugins/nat/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/plugins/nat/CMakeLists.txt b/src/plugins/nat/CMakeLists.txt
index 372bbd61bb3..edba893cafe 100644
--- a/src/plugins/nat/CMakeLists.txt
+++ b/src/plugins/nat/CMakeLists.txt
@@ -11,6 +11,21 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+set(NAT_SRCS
+ lib/alloc.c
+)
+
+set(NAT_HEADERS
+ lib/alloc.h
+)
+
+add_vpp_library(nat
+ SOURCES ${NAT_SRCS}
+ LINK_LIBRARIES m
+ INSTALL_HEADERS ${NAT_HEADERS}
+ COMPONENT libnat
+)
+
add_vpp_plugin(nat
SOURCES
nat.c