aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nat/CMakeLists.txt
diff options
context:
space:
mode:
authorFilip Varga <fivarga@cisco.com>2020-11-02 12:11:12 +0100
committerOle Tr�an <otroan@employees.org>2020-11-13 10:06:57 +0000
commitb227aa699faabd79d6f3e8c43c0a912086b0c95e (patch)
treefcd40c449b6d653d0519c298859493deae167c5c /src/plugins/nat/CMakeLists.txt
parent80f0b88fc388c82627dafef19c01f4c4536bbfa2 (diff)
nat: api,cli and test update & cleanup
Cleanup of print functions in api file, splitting functionality of cleanup callbacks for ED and EI NAT. Updating and fixing API & CLI calls. Type: refactor Change-Id: I7a9dc4c8b1d2ca29db4754be7dfa4f698942127a Signed-off-by: Filip Varga <fivarga@cisco.com>
Diffstat (limited to 'src/plugins/nat/CMakeLists.txt')
-rw-r--r--src/plugins/nat/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/src/plugins/nat/CMakeLists.txt b/src/plugins/nat/CMakeLists.txt
index 47a84cb830b..054ad687f75 100644
--- a/src/plugins/nat/CMakeLists.txt
+++ b/src/plugins/nat/CMakeLists.txt
@@ -26,7 +26,7 @@ add_vpp_library(nat
add_vpp_plugin(nat
SOURCES
nat.c
- nat_api.c
+ nat44_api.c
in2out.c
in2out_ed.c
out2in.c
@@ -51,16 +51,9 @@ add_vpp_plugin(nat
out2in_ed.c
API_FILES
- nat.api
+ nat44.api
nat_types.api
- API_TEST_SOURCES
- nat_test.c
-
- INSTALL_HEADERS
- nat_all_api_h.h
- nat_msg_enum.h
-
LINK_LIBRARIES nat
)