aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nat/CMakeLists.txt
diff options
context:
space:
mode:
authorFilip Varga <fivarga@cisco.com>2020-09-29 16:53:20 +0200
committerFilip Varga <fivarga@cisco.com>2020-10-09 10:20:21 +0000
commitdd9eae5c29a4379943e60ddf6b7ab96b8e154040 (patch)
tree5e915d1377ffaf452e9dfa1945516d44c1ac8355 /src/plugins/nat/CMakeLists.txt
parentaa04395573f26fe420d7eb9ca329732b7197fe52 (diff)
nat: ipfix logging separation & refactor
Type: refactor Change-Id: I8785e4987e4f60361072440d0c3c6954c9c12394 Signed-off-by: Filip Varga <fivarga@cisco.com>
Diffstat (limited to 'src/plugins/nat/CMakeLists.txt')
-rw-r--r--src/plugins/nat/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/plugins/nat/CMakeLists.txt b/src/plugins/nat/CMakeLists.txt
index 727f57904af..47a84cb830b 100644
--- a/src/plugins/nat/CMakeLists.txt
+++ b/src/plugins/nat/CMakeLists.txt
@@ -15,9 +15,11 @@ set(CMAKE_VERBOSE_MAKEFILE ON)
add_vpp_library(nat
SOURCES
+ lib/ipfix_logging.c
lib/alloc.c
INSTALL_HEADERS
+ lib/ipfix_logging.h
lib/alloc.h
)
@@ -29,7 +31,6 @@ add_vpp_plugin(nat
in2out_ed.c
out2in.c
out2in_ed.c
- nat_ipfix_logging.c
nat_dpo.c
nat44_cli.c
nat44_handoff.c
@@ -59,6 +60,8 @@ add_vpp_plugin(nat
INSTALL_HEADERS
nat_all_api_h.h
nat_msg_enum.h
+
+ LINK_LIBRARIES nat
)
add_vpp_plugin(dslite