aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nsh/CMakeLists.txt
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2018-08-27 20:27:43 +0800
committerDamjan Marion <dmarion@me.com>2018-08-28 06:04:57 +0000
commitd313f9e6f7c6d50aac189668a67bf13b86dd791c (patch)
tree0f92babad6891604e79f521de136b0a2bb946fbc /src/plugins/nsh/CMakeLists.txt
parenta5679e86af3d06df46edbf2654d48103e05c4b48 (diff)
Port NSH plugin to VPP
Please refer to https://wiki.fd.io/view/NSH_SFC Change-Id: Iba7e33e4dbb064c1527aaddbe8dce4b6b63a627a Signed-off-by: Hongjun Ni <hongjun.ni@intel.com> Signed-off-by: Keith Burns (alagalah) <alagalah@gmail.com>
Diffstat (limited to 'src/plugins/nsh/CMakeLists.txt')
-rw-r--r--src/plugins/nsh/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/plugins/nsh/CMakeLists.txt b/src/plugins/nsh/CMakeLists.txt
new file mode 100644
index 00000000000..866b3704c0d
--- /dev/null
+++ b/src/plugins/nsh/CMakeLists.txt
@@ -0,0 +1,33 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(nsh
+ SOURCES
+ nsh.c
+ nsh_output.c
+ nsh_pop.c
+ nsh-md2-ioam/nsh_md2_ioam.c
+ nsh-md2-ioam/nsh_md2_ioam_api.c
+ nsh-md2-ioam/md2_ioam_transit.c
+ nsh-md2-ioam/nsh_md2_ioam_trace.c
+ nsh-md2-ioam/export-nsh-md2-ioam/nsh_md2_ioam_export.c
+ nsh-md2-ioam/export-nsh-md2-ioam/nsh_md2_ioam_export_thread.c
+ nsh-md2-ioam/export-nsh-md2-ioam/nsh_md2_ioam_node.c
+
+ API_FILES
+ nsh.api
+
+ API_TEST_SOURCES
+ nsh_test.c
+)
+