aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nsim/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2018-09-21 13:10:28 -0400
committerDamjan Marion <dmarion@me.com>2018-09-24 08:08:34 +0000
commit9e3252b5cec76dddb9877e593c799ebe15cae0af (patch)
tree37a848d9e9bb0ff59f8b54e5bab9380df39a4ebc /src/plugins/nsim/CMakeLists.txt
parentbdc0e6b7204ea0211d4f7881497e4306586fb9ef (diff)
Network delay simulator plugin
Change-Id: I4a70c7df8f0cb368a4e1cb16f30eeef5c6058c79 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'src/plugins/nsim/CMakeLists.txt')
-rw-r--r--src/plugins/nsim/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/plugins/nsim/CMakeLists.txt b/src/plugins/nsim/CMakeLists.txt
new file mode 100644
index 00000000000..6b261f8d266
--- /dev/null
+++ b/src/plugins/nsim/CMakeLists.txt
@@ -0,0 +1,33 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(nsim
+ SOURCES
+ nsim.c
+ node.c
+ nsim_input.c
+
+ MULTIARCH_SOURCES
+ nsim_input.c
+ node.c
+
+ API_FILES
+ nsim.api
+
+ INSTALL_HEADERS
+ nsim_all_api_h.h
+ nsim_msg_enum.h
+
+ API_TEST_SOURCES
+ nsim_test.c
+)