aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/quic/CMakeLists.txt
diff options
context:
space:
mode:
authorNathan Skrzypczak <nathan.skrzypczak@gmail.com>2019-03-19 13:57:31 +0100
committerFlorin Coras <florin.coras@gmail.com>2019-03-29 15:57:30 +0000
commit60f3e6547aa75a31fad1f78bea11c950cc30d63c (patch)
tree4df1f649f10272c5f276754d6b0dbecaaa08784a /src/plugins/quic/CMakeLists.txt
parentdb4cae5d438e5114a19df38acbb9e1dd6c99fe3f (diff)
Integrate first QUIC protocol implementation
Currently supports on single stream exposed through standard internal APIs Based on libquicly & picotls by h2o Change-Id: I7bc1ec0e399d1fb02bfd1da91aa7410076d08d14 Signed-off-by: Nathan Skrzypczak <nathan.skrzypczak@gmail.com>
Diffstat (limited to 'src/plugins/quic/CMakeLists.txt')
-rw-r--r--src/plugins/quic/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/plugins/quic/CMakeLists.txt b/src/plugins/quic/CMakeLists.txt
new file mode 100644
index 00000000000..ccd49682e8c
--- /dev/null
+++ b/src/plugins/quic/CMakeLists.txt
@@ -0,0 +1,43 @@
+
+# Copyright (c) 2019 Cisco
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+message(STATUS "Looking for quicly")
+unset(QUIC_LINK_LIBRARIES)
+
+find_path(QUICLY_INCLUDE_DIR NAMES quicly.h)
+find_library (QUICLY_LIBRARY NAMES "libquicly.a")
+find_library (PICOTLS_CORE_LIBRARY NAMES "libpicotls-core.a")
+find_library (PICOTLS_OPENSSL_LIBRARY NAMES "libpicotls-openssl.a")
+
+list(APPEND QUIC_LINK_LIBRARIES
+ ${QUICLY_LIBRARY}
+ ${PICOTLS_CORE_LIBRARY}
+ ${PICOTLS_OPENSSL_LIBRARY}
+)
+
+if(QUICLY_INCLUDE_DIR AND QUIC_LINK_LIBRARIES)
+ include_directories (${QUICLY_INCLUDE_DIR})
+ add_vpp_plugin(quic
+ SOURCES
+ quic.c
+
+ INSTALL_HEADERS
+ quic.h
+
+ LINK_LIBRARIES ${QUIC_LINK_LIBRARIES}
+ )
+ message(STATUS "Found quicly in ${QUICLY_INCLUDE_DIR}")
+else()
+ message(WARNING "-- quicly not found - quic_plugin disabled")
+endif()