aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/rdma/CMakeLists.txt
diff options
context:
space:
mode:
authorBenoît Ganne <bganne@cisco.com>2019-10-15 10:51:11 +0200
committerDamjan Marion <dmarion@me.com>2019-10-16 18:35:51 +0000
commit812afe712b62484b4390fa048c76fe8bf4cd0a12 (patch)
tree4000e7ac4b27b572542177b3997a712c1f24be18 /src/plugins/rdma/CMakeLists.txt
parente8c9f4f1c07f41986c50a744eee8ed4897178fda (diff)
rdma: add rdma API
Type: feature Change-Id: I590612989cb3c114f8d99227ad36c3434e998597 Signed-off-by: Benoît Ganne <bganne@cisco.com>
Diffstat (limited to 'src/plugins/rdma/CMakeLists.txt')
-rw-r--r--src/plugins/rdma/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/plugins/rdma/CMakeLists.txt b/src/plugins/rdma/CMakeLists.txt
index 432330dc55d..eaf747db54f 100644
--- a/src/plugins/rdma/CMakeLists.txt
+++ b/src/plugins/rdma/CMakeLists.txt
@@ -43,10 +43,12 @@ include_directories(${IBVERBS_INCLUDE_DIR})
add_vpp_plugin(rdma
SOURCES
+ api.c
cli.c
device.c
format.c
plugin.c
+ unformat.c
input.c
output.c
@@ -54,6 +56,13 @@ add_vpp_plugin(rdma
input.c
output.c
+ API_FILES
+ rdma.api
+
+ API_TEST_SOURCES
+ unformat.c
+ test_api.c
+
LINK_FLAGS
"${RDMA_LINK_FLAGS}"