aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/srmpls/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Hutton <schutton@cisco.com>2024-05-03 07:40:42 -0700
committerDamjan Marion <dmarion@0xa5.net>2024-05-14 07:53:35 +0000
commit182d8b2ddba098f99029ed82e44960f3dfd18987 (patch)
tree5e6207f795dba2e2be150c1b3ca4c150106e5c3a /src/plugins/srmpls/CMakeLists.txt
parent9850d301b0dc87cadf05999cf210f1f7b731a327 (diff)
sr: move srmpls to a plugin
Move sr_mpls folder under vnet to the plugin folder, update cmake configuration and header paths, and add plugin.c to register plugin. JIRA: VPP-2054 Type: improvement Change-Id: I1ad6f287f67eb0c35588c339bcd51218fadf5f8e Signed-off-by: Scott Hutton <schutton@cisco.com>
Diffstat (limited to 'src/plugins/srmpls/CMakeLists.txt')
-rw-r--r--src/plugins/srmpls/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/plugins/srmpls/CMakeLists.txt b/src/plugins/srmpls/CMakeLists.txt
new file mode 100644
index 00000000000..25905d31e1b
--- /dev/null
+++ b/src/plugins/srmpls/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Copyright (c) 2024 Cisco and/or its affiliates
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(srmpls
+ SOURCES
+ sr_mpls_policy.c
+ sr_mpls_steering.c
+ sr_mpls_api.c
+ plugin.c
+
+ INSTALL_HEADERS
+ sr_mpls.h
+
+ API_FILES
+ sr_mpls.api
+
+ # This might need to be VAT_AUTO_TEST? Not documented
+ API_TEST_SOURCES
+ sr_mpls_test.c
+)