aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/srv6-ad-flow/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois Clad <fclad@cisco.com>2020-04-03 11:33:02 +0200
committerDamjan Marion <dmarion@me.com>2021-03-31 14:13:06 +0000
commited7c62a3048f8a976803ba91612e99a49ed0342e (patch)
tree79b2705e6a162c849f774c53afd57994fda027cf /src/plugins/srv6-ad-flow/CMakeLists.txt
parent17bd30384cb3441d11cd65a00a3af76885288b78 (diff)
srv6-ad-flow: SRv6 Per-Flow Dynamic Proxy
Type: feature Change-Id: Ibfc412200ef5932fa40423075967df6d9156f3ed Signed-off-by: Francois Clad <fclad@cisco.com>
Diffstat (limited to 'src/plugins/srv6-ad-flow/CMakeLists.txt')
-rw-r--r--src/plugins/srv6-ad-flow/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/plugins/srv6-ad-flow/CMakeLists.txt b/src/plugins/srv6-ad-flow/CMakeLists.txt
new file mode 100644
index 00000000000..63cb457e5ae
--- /dev/null
+++ b/src/plugins/srv6-ad-flow/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(srv6adflow
+ SOURCES
+ ad-flow.c
+ node.c
+
+ INSTALL_HEADERS
+ ad-flow.h
+)