aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/srv6-mobile/CMakeLists.txt
diff options
context:
space:
mode:
authorTakeru Hayasaka <hayatake396@gmail.com>2022-10-28 04:26:05 +0900
committerAndrew Yourtchenko <ayourtch@gmail.com>2023-12-20 17:30:19 +0000
commit68ac244283b60cbaf6356ab732f1d31583bb3e7a (patch)
treeeafd76834ecd0aaa77ac4f9a54629636489d5bfd /src/plugins/srv6-mobile/CMakeLists.txt
parent69f800fbfd559c8db21d064ceeca5f81fb1f0021 (diff)
srv6-mobile: Implement SRv6 mobile API funcs
This merge request adds the feature to manipulate localsids and policies for SRv6 mobile via API. Type: feature Signed-off-by: Takeru Hayasaka <hayatake396@gmail.com> Change-Id: Ibb46bf71ae1d9d4591ce2c8ccf66f520887dad70
Diffstat (limited to 'src/plugins/srv6-mobile/CMakeLists.txt')
-rw-r--r--src/plugins/srv6-mobile/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/plugins/srv6-mobile/CMakeLists.txt b/src/plugins/srv6-mobile/CMakeLists.txt
index 5a9945c2e4f..a917c8ded82 100644
--- a/src/plugins/srv6-mobile/CMakeLists.txt
+++ b/src/plugins/srv6-mobile/CMakeLists.txt
@@ -21,6 +21,11 @@ add_vpp_plugin(srv6mobile
gtp6_d_di.c
gtp6_dt.c
node.c
+ sr_mobile_api.c
+
+ API_FILES
+ sr_mobile.api
+ sr_mobile_types.api
INSTALL_HEADERS
mobile.h