aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/svs/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2018-10-01 01:42:13 -0700
committerDamjan Marion <dmarion@me.com>2018-10-01 17:08:55 +0000
commitd1e68ab77e57f3f170c989d9f73b6a44648b4f60 (patch)
tree8b68e26b2f89ac98a0ba775cb40ed1306fecbeca /src/plugins/svs/CMakeLists.txt
parent346ed07526326f0b1c48ac356d5d786ff9ae0013 (diff)
Source VRF Select
match against a packet's source address to determine the VRF for the subsequent destination address lookup. Change-Id: I48ee0ef54dcb891f0ec7f879e4d3b925a0ed0081 Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/plugins/svs/CMakeLists.txt')
-rw-r--r--src/plugins/svs/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/plugins/svs/CMakeLists.txt b/src/plugins/svs/CMakeLists.txt
new file mode 100644
index 00000000000..7d915b4878f
--- /dev/null
+++ b/src/plugins/svs/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(svs
+ SOURCES
+ svs_api.c
+ svs.c
+
+ API_FILES
+ svs.api
+
+ INSTALL_HEADERS
+ svs_all_api_h.h
+ svs_msg_enum.h
+)