aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/tlsopenssl/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2020-11-19 13:38:26 -0800
committerDave Barach <openvpp@barachs.net>2021-02-09 21:33:19 +0000
commit4b47ee26cba610b26bbfc088736846541bee7be3 (patch)
treecb6aedb8a7ba69140bda4709dbff084d91ffff90 /src/plugins/tlsopenssl/CMakeLists.txt
parentda2305fb874a7cf6573267adb87166564e328396 (diff)
tls: dtls initial implementation
Type: feature Basic dtls transport protocol implementation that relies on openssl wire protocol implementation. Retries/timeouts not yet supported. To test using vcl test apps, first ensure all arp entries are properly resolved and subsequently: server: vcl_server -p dtls 1234 client: vcl_client -p dtls <server-ip> 1234 -U -N 2000000 -T 1460 -X Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: I04b4516a8fe9ce85ba230bcdd891f33a900046ed
Diffstat (limited to 'src/plugins/tlsopenssl/CMakeLists.txt')
-rw-r--r--src/plugins/tlsopenssl/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/tlsopenssl/CMakeLists.txt b/src/plugins/tlsopenssl/CMakeLists.txt
index 61d3638a39a..eb67e4cceaf 100644
--- a/src/plugins/tlsopenssl/CMakeLists.txt
+++ b/src/plugins/tlsopenssl/CMakeLists.txt
@@ -20,6 +20,7 @@ if(OPENSSL_FOUND AND OPENSSL_VERSION VERSION_GREATER_EQUAL "1.1.0")
tls_openssl.c
tls_openssl_api.c
tls_async.c
+ dtls_bio.c
API_FILES
tls_openssl.api