aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/tlsopenssl/CMakeLists.txt
diff options
context:
space:
mode:
authorPing Yu <ping.yu@intel.com>2019-08-19 07:01:17 -0400
committerPing Yu <ping.yu@intel.com>2019-08-20 13:36:17 +0000
commitbe4d1aa2c58efa8287bca8795bc4a83cb448993a (patch)
treec726b2c3ce5ee0e98f88aa8db1d16ce1d6b9ee32 /src/plugins/tlsopenssl/CMakeLists.txt
parente71748291171e53158e2d36d8f413fed1a137013 (diff)
tls: Add C API for TLS openssl to set engine
Type: feature Parameters of the engine can be set by C API. After this patch, it is easier to integrate TLS into CSIT test. Change-Id: I063cabf613aabbfad831727551579328705afb41 Signed-off-by: Ping Yu <ping.yu@intel.com>
Diffstat (limited to 'src/plugins/tlsopenssl/CMakeLists.txt')
-rw-r--r--src/plugins/tlsopenssl/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/plugins/tlsopenssl/CMakeLists.txt b/src/plugins/tlsopenssl/CMakeLists.txt
index ad34cfaa90d..07b587b4ca3 100644
--- a/src/plugins/tlsopenssl/CMakeLists.txt
+++ b/src/plugins/tlsopenssl/CMakeLists.txt
@@ -17,8 +17,19 @@ if(OPENSSL_FOUND)
add_vpp_plugin(tlsopenssl
SOURCES
tls_openssl.c
+ tls_openssl_api.c
tls_async.c
+ API_FILES
+ tls_openssl.api
+
+ INSTALL_HEADERS
+ tls_openssl_all_api_h.h
+ tls_openssl_msg_enum.h
+
+ API_TEST_SOURCES
+ tls_openssl_test.c
+
LINK_LIBRARIES
${OPENSSL_LIBRARIES}
)