aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/tracenode/CMakeLists.txt
diff options
context:
space:
mode:
authorMaxime Peim <mpeim@cisco.com>2023-07-11 09:45:56 +0200
committerBeno�t Ganne <bganne@cisco.com>2023-09-04 07:57:44 +0000
commit77812045e720d1434dd36a1db90c35daad0c8e00 (patch)
tree4588ff65542af1edec3474010c5a8120efb04705 /src/plugins/tracenode/CMakeLists.txt
parent2ceb818f8eca4b8aebd0a4f2b36a641c832d8819 (diff)
tracenode: filtering feature
In order to be able to filter on encapsulated packet, a new node has been added to the ip4/6-unicast arcs. Type: feature Change-Id: I1e8ee05bc6d0fce20cadd8319c81bab260c17d21 Signed-off-by: Maxime Peim <mpeim@cisco.com>
Diffstat (limited to 'src/plugins/tracenode/CMakeLists.txt')
-rw-r--r--src/plugins/tracenode/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/plugins/tracenode/CMakeLists.txt b/src/plugins/tracenode/CMakeLists.txt
new file mode 100644
index 00000000000..6b6ba2e9865
--- /dev/null
+++ b/src/plugins/tracenode/CMakeLists.txt
@@ -0,0 +1,37 @@
+
+# Copyright (c) 2023 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(tracenode
+ SOURCES
+ node.c
+ api.c
+ cli.c
+ plugin.c
+ tracenode.c
+
+ MULTIARCH_SOURCES
+ node.c
+
+ API_FILES
+ tracenode.api
+
+ INSTALL_HEADERS
+ tracenode.h
+
+ API_TEST_SOURCES
+ test.c
+
+ COMPONENT
+ vpp-plugin-devtools
+)