aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/unittest/CMakeLists.txt
diff options
context:
space:
mode:
authorRyujiro Shibuya <ryujiro.shibuya@owmobility.com>2019-12-25 07:40:54 +0000
committerDave Barach <openvpp@barachs.net>2020-02-25 19:18:49 +0000
commit234fe894d80a6ebc7e457bc86f2eea80d5ef01ea (patch)
tree89d1e728091669f4199f668b2438b26ab3f95d9b /src/plugins/unittest/CMakeLists.txt
parentf22f4e562e1b922cff036ef628b77fd2d479d015 (diff)
session svm: tracking segment memory usage
1. segment manager would attempt to balance the usages across the segments, when it allocate fifos 2. the memory presure level is determined per fifo-segment 3. updated unit test 4. updated cli output for segments Type: feature Signed-off-by: Ryujiro Shibuya <ryujiro.shibuya@owmobility.com> Change-Id: I2923f3e0a43dd919196a0cb2cd55e098fde6cf66
Diffstat (limited to 'src/plugins/unittest/CMakeLists.txt')
-rw-r--r--src/plugins/unittest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/unittest/CMakeLists.txt b/src/plugins/unittest/CMakeLists.txt
index a029e0e3259..e75b96ff265 100644
--- a/src/plugins/unittest/CMakeLists.txt
+++ b/src/plugins/unittest/CMakeLists.txt
@@ -36,6 +36,7 @@ add_vpp_plugin(unittest
sparse_vec_test.c
string_test.c
svm_fifo_test.c
+ segment_manager_test.c
tcp_test.c
test_buffer.c
unittest.c