aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/unittest/CMakeLists.txt
diff options
context:
space:
mode:
authorfituldo <filip.tehlar@gmail.com>2019-04-12 12:26:43 +0000
committerDamjan Marion <dmarion@me.com>2019-04-14 14:44:56 +0000
commit89e66434a2c93a07d7e913bb66b2be5e6e6df14c (patch)
tree17b3ed7dfd68283b4a3d6f0fd6deed3336a19426 /src/plugins/unittest/CMakeLists.txt
parent4e08316f3ec2c98165f156c6551f1e6557931739 (diff)
crypto: add support for AES-CTR cipher
Change-Id: I7d84bab7768421ed37813702c0413e52167f41ab Signed-off-by: Filip Tehlar <ftehlar@cisco.com>
Diffstat (limited to 'src/plugins/unittest/CMakeLists.txt')
-rw-r--r--src/plugins/unittest/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/plugins/unittest/CMakeLists.txt b/src/plugins/unittest/CMakeLists.txt
index 55766176fff..60a7cc166ab 100644
--- a/src/plugins/unittest/CMakeLists.txt
+++ b/src/plugins/unittest/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2018 Cisco and/or its affiliates.
+# Copyright (c) 2018-2019 Cisco and/or its affiliates.
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at:
@@ -18,6 +18,7 @@ add_vpp_plugin(unittest
crypto_test.c
crypto/aes_cbc.c
crypto/aes_gcm.c
+ crypto/aes_ctr.c
crypto/rfc2202_hmac_sha1.c
crypto/rfc2202_hmac_md5.c
crypto/rfc4231.c