aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/unittest/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-11-18 17:16:49 -0500
committerDave Barach <dave@barachs.net>2019-11-18 17:17:40 -0500
commitc17fc44735b509b22476e8663e33be62678837a2 (patch)
tree4e58b24de8b81e1dc95ad1bea5b41ca8d3a7e271 /src/plugins/unittest/CMakeLists.txt
parent920180e5e0722c78c258ff26476fd5efa434032d (diff)
vlib: improve code coverage in src/vlib
Type: test Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I2dc4c09730f77931a2b484a6dd5dc669068f8e57
Diffstat (limited to 'src/plugins/unittest/CMakeLists.txt')
-rw-r--r--src/plugins/unittest/CMakeLists.txt17
1 files changed, 9 insertions, 8 deletions
diff --git a/src/plugins/unittest/CMakeLists.txt b/src/plugins/unittest/CMakeLists.txt
index e074d317b0a..a029e0e3259 100644
--- a/src/plugins/unittest/CMakeLists.txt
+++ b/src/plugins/unittest/CMakeLists.txt
@@ -15,29 +15,30 @@ add_vpp_plugin(unittest
SOURCES
bier_test.c
bihash_test.c
- crypto_test.c
crypto/aes_cbc.c
- crypto/aes_gcm.c
crypto/aes_ctr.c
- crypto/rfc2202_hmac_sha1.c
+ crypto/aes_gcm.c
crypto/rfc2202_hmac_md5.c
+ crypto/rfc2202_hmac_sha1.c
crypto/rfc4231.c
+ crypto_test.c
fib_test.c
- ipsec_test.c
interface_test.c
+ ipsec_test.c
lisp_cp_test.c
llist_test.c
mactime_test.c
- mpcap_node.c
mfib_test.c
+ mpcap_node.c
punt_test.c
rbtree_test.c
session_test.c
- string_test.c
- tcp_test.c
sparse_vec_test.c
+ string_test.c
svm_fifo_test.c
+ tcp_test.c
+ test_buffer.c
unittest.c
util_test.c
- test_buffer.c
+ vlib_test.c
)