aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/vhost/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Luong <sluong@cisco.com>2022-10-19 12:46:29 -0700
committerDamjan Marion <dmarion@0xa5.net>2022-12-02 13:43:11 +0000
commit7eba44d1ec54982636f830a4859027218ca56832 (patch)
tree6447cda45a430c8a735b92be2b13b41b18e1f8a1 /src/plugins/vhost/CMakeLists.txt
parenta6d16b71308f1badf4b362d26d2326a2977fe462 (diff)
vhost: convert vhost device driver to a plugin
convert vhost device driver to a plugin as described in https://jira.fd.io/browse/VPP-2065 Type: improvement Signed-off-by: Steven Luong <sluong@cisco.com> Change-Id: Ibfe2f351bcaed36a04b136d082ae414145dd37b5
Diffstat (limited to 'src/plugins/vhost/CMakeLists.txt')
-rw-r--r--src/plugins/vhost/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/plugins/vhost/CMakeLists.txt b/src/plugins/vhost/CMakeLists.txt
new file mode 100644
index 00000000000..f72d9f20346
--- /dev/null
+++ b/src/plugins/vhost/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Copyright (c) 2020 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(vhost
+ SOURCES
+ plugin.c
+ vhost_user.c
+ vhost_user_api.c
+ vhost_user_input.c
+ vhost_user_output.c
+ vhost_std.h
+ vhost_user.h
+ vhost_user_inline.h
+ virtio_std.h
+
+ MULTIARCH_SOURCES
+ vhost_user_input.c
+ vhost_user_output.c
+
+ API_FILES
+ vhost_user.api
+)