aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/vmxnet3/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Luong <sluong@cisco.com>2018-03-18 08:01:27 -0700
committerSteven <sluong@cisco.com>2018-09-14 14:27:41 -0700
commitdf7f8e8cffcc43531f7daeda44d436b60e538141 (patch)
tree1ff98cd205995a3c499048c5f93b11c9feda39c6 /src/plugins/vmxnet3/CMakeLists.txt
parentef90ed08fbcde7535b4a789349b39dc25798c77d (diff)
vmxnet3 device driver
Implemented vmxnet3 deivice driver for VMWare ESXi. Tested with Ubuntu 18.04 connected to ESXi 6.0 Ubuntu-18.04 (VPP) --- ESXi-6.0 Change-Id: I85fbc86f2d8532b017bc4271612d17e24e498e4d Signed-off-by: Steven Luong <sluong@cisco.com>
Diffstat (limited to 'src/plugins/vmxnet3/CMakeLists.txt')
-rw-r--r--src/plugins/vmxnet3/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/plugins/vmxnet3/CMakeLists.txt b/src/plugins/vmxnet3/CMakeLists.txt
new file mode 100644
index 00000000000..a81d8d59387
--- /dev/null
+++ b/src/plugins/vmxnet3/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(vmxnet3
+ SOURCES
+ cli.c
+ format.c
+ input.c
+ output.c
+ plugin.c
+ vmxnet3.c
+ vmxnet3_api.c
+
+ MULTIARCH_SOURCES
+ input.c
+ output.c
+
+ API_FILES
+ vmxnet3.api
+
+ API_TEST_SOURCES
+ vmxnet3_test.c
+
+ INSTALL_HEADERS
+ vmxnet3_all_api_h.h
+ vmxnet3_msg_enum.h
+)